[cs615asa] EC2 credential problem

czhang13 czhang13 at stevens.edu
Sun Mar 17 22:52:06 EDT 2013

On Sun, 17 Mar 2013 22:03:16 -0400, Jan Schaumann wrote:
> Chao <czhang13 at stevens.edu> wrote:
>> I used to use the x.509 certificate to launch instance from 
>> Linux-lab
>> and woks fine. But recently when I changed to use the 
>> the ec2 tools keeps ask me for pk- and cert- file. (The secret key
>> works fine on my own computer)
>> For example , I test ec2-describe-regions and get following error:
>> "Required option '-K, --private-key KEY' missing"
>> Don't know if you guys have had this kind issue. Hope I can get some
>> suggestions, thanks.
> It's hard to say what might be wrong.  You need to provide more 
> details,
> such as what the exact command is you're invoking, and what your
> environment looks like.  Use the env(1) command and the AWS online
> documentation to ensure you have everything set up correctly; if you
> still can't figure it out, send all relevant details to the list.
> -Jan

Hi Professor,

My environment:
AWS_SECRET_KEY=..(checked, which works well using boto)

Commands like:
ec2-run-instances any option
ec2-create-volume any option

all the same error:
Required option '-K, --private-key KEY' missing (-h for usage)

I did some google but still get no good reference.


More information about the cs615asa mailing list